How to create an Altair wallet address using the Polkadot.js.extension

Many people have recently received a letter from Coinlist, asking to create an Altair wallet address to provide to Coinlist in order to get airdrop.

You can watch this very short video to learn how to create an account with Polkadot.js.extension to get an Altair wallet address:

Once you have received your AIR in your wallet, you can watch this video to learn how to see the balance:

There is also a short written manual here where you can see the same instructions with screenshots:

Note, that there is more than one way to create a wallet address - this manual focuses on how to do it with the Polkadot.js.extension.

Also, if you have Clover wallet installed, make sure to disable it as we have seen users having issues with Polkadot.js.extension when both are installed.

4 Likes

Hi, Rhano and thanks for this - I have a couple of doubts:

1 - I created an account named “Altair” on Polkadot extension - address starts with K
2 - When I go to Polkadot/Substrate Portal the account named ALTAIR (EXTENSION) address starts with 4

  • I know I can send/use the Polkadot extension address which starts with K, but why does my address on Polkadot.org start with 4?
  • I also noticed that in the demo there is a 2nd “controller” account [similar to what I have on CFG] - do I need to create this account, even though [as I understand] this is not explained?
    Thanks in advance,
    Ricky

Hi @Kiwiprofesor,

To answer your questions.

2 - Make sure that you are in the Altair network in the Polkadot/Substrate Portal. I suspect that you are in the Centrifuge network?

If that’s not the case, then try to change this setting:

Do not worry about the controller account for now. It will not be relevant until staking of AIR is enabled (the Altair network need to go through some Runtime Upgrades first).

Once you have created an account with Polkadot.js.extension, you basically have a wallet address for every supported network (i.e. a DOT wallet address, a KSM wallet address, a CFG wallet address etc.).

But all of these wallet addresses are just different representations of the same public-private key.

You can visualize it like this:

You can also see the different wallet addresses in your account by going to the Polkadot/Substrate Portal and changing the network for the wallet address you want to see (like explained in my first answer). Just make sure to change the chain to that network (or “Allow use on any chain”) in the dropdown menu in the extension as well.

1 Like

Hi Rhano, thanks for your message again - sorry but still confused:

I am on the Altair network [see screenshot] but my Altair account starts with 4.

I think I may have created that account on the CFG network originally? [hence starting with 4] - so I suppose I have to delete/cancel it and create another one on the Altair network?

Apologies for taking your precious time

No need to apologize mate.

You don’t have to delete - did you try the suggestion I gave you in my first response (second screenshot)?

I added it after my initial response, so you might not have seen it in the first place.

I think I did what you said - meaning change to the Altair network on the Polkadot extension?

So, I am on the Altair network BOTH on the Polkadot/Substrate Portal, and on the Polkadot extension [see screenshots], but my address in both places starts with “4”.

There’s obviously something glaring that I am missing but unfortunately I can’t see it.FireShot Capture 003 - Polkadot_Substrate Portal - polkadot.js.org
Screenshot 2021-11-01 234736.

Hello Kiwiprofesor

You should change settings here:

I’m sure that now your setting is Centrifuge and not Substrate
You can also select Altair.

And if you have Clover Extension please switch off this extension.

1 Like

Hey

, thanks for your reply - I’m attaching a couple of screenshots to show you what’s up.First I set the extension to Substrate and refreshed - this is what I got [address on extension and portal starting with 4]:


Next I set the extension to Altair and refreshed again, same thing [I think]:


Is there something I am doing wrong?

It doesn’t seem like you are doing anything wrong. All the suggestions we have given to you above have worked for other users.

Just be 100% sure. Make sure to change the settings that ImdioR is suggesting AND do this too:

If that doesn’t work, then my last suggestion would be to try from another browser (i.e. if you’re using Chrome, try using Firefox and vice versa).

So try installing Polkadot.js.extension in another browser and import your account there, by using the JSON file or your 12 word seed phrase. See if that resolves the issue.

1 Like

Hello KiwiProfesor
All is ok, just you insert not “correct” settings if we call them incorrect.
However please set like on my screenshot here
Settings - General- address prefix - Default for the connected node

And you will be fine.

Let me know if these steps help you.

1 Like

Rhano
After setting prefix he should be fine

1 Like

You’re a genius! yep you’re right, I made those changes and now I have my “k” Altair address.
Thanks a lot for your help and patience.
Ricky Rutledge

1 Like

You are welcome
Feel free to contact.
Be happy, be Centrifuge!